spring版本不兼容JDK问题

作者: 日期:2019-08-20

在实验书上凯发体育网址spring项目的时候出现一个问题,导入包和使用注释的时候eclipse出现报错。

导入包报错:the import org cannot be resolved

注释报错:component cannot be resolved to a type

网上查询后发现是spring版本和jdk版本之间出现不兼容,我用的是spring4,并不兼容jdk11,我在网上下载了jdk8。

对应关系见贴:

修改jdk的方法详见贴:

打开eclipse- window- preferences- java- install jres点击add,添加jdk8的目录

右击项目build path- config build path,将libraries的jre替换为1.8

改java compiler为1.8

 

同样要改的还有project faces

 完成点apply以后eclipse就不报错了。

最新版本的spring5支持jdk11,使用spring5的应该不会出现这个问题。

首页
电话
短信
联系